Tag Archives: System Requirements

  • System Requirements for Act! 18

    System Requirements for Act! 18

    Act! v18, the latest release of Act!, is expected to be made available on December 8th.With this release, there is a strong encouragement for anyone still using Act! v15 (2013) to upgrade, as this is the last time they will be eligible for upgrade pricing. There are not any official specifications for this release of Act! […]