Potential Pitfalls for Act! users upgrading to Windows 10

Potential Pitfalls for Act! Banner

Technology is moving forward at an incredible pace, people are finding more than ever the need to upgrade their hardware every few years.
What does this mean for those that use Act!?

Well for anyone using Act! v16 or earlier this can be a real issue as most new PC's and Laptops are coming preinstalled with Windows 10, the latest Operating System (OS) from MIcrosoft.
Only Act! v17.2 or higher is compatible and supported on Windows 10, and Swiftpage has no plans to update Act! v16 or earlier to make it compatible.

Frequently Asked Questions

  • Can I install and use earlier versions of Act! on Windows 10?
    • Yes you can install earlier versions with minimal issues, we have seen versions as early as Act! 2012 installed on Windows 10, however there are some functions that will not work as expected.
  • So what issues should I expect?
    • Error message during installation that does not actually prevent installation.
    • Error message that Act! did not close correctly when closing Act!
    • Prompt to fill in the phone area code each time Act! is launched.
    • Act! crashes unexpectedly when attempting to use the Documents Tab.

What Should I Do?

At one stage or another you are going to be faced with the need to upgrade your systems or purchase a new computer.
In order to be able to continue to use Act! to its full potential, the best course of action is to upgrade to the latest version.
This is especially important if you are a user who is working on a version of Act! that is 5+ years old, as not only are you limited to hardware and software that supports your current version, you are actually missing out on a range of new features and improvements that have been added into Act! that could actually be of benefit to you and your business.

Further Resources

Refer to these Knowledgebase articles for further information:

Posted in: